このガイドは、電話機でSIPアカウント設定を構成し、登録要求を送信した後、登録失敗が発生したユーザーを対象としています。
対応製品:すべての電話モデル。
対応ファームウェア:対応モデル向けのすべてのファームウェアバージョン。
このドキュメントは、SIPアカウントの登録障害をトラブルシューティングする必要があるユーザー向けに設計されています。
シナリオ1:アカウント設定の送信後、すぐに登録がタイムアウトする。
シナリオ2:電話機がしばらく正常に動作した後、登録がタイムアウトする。
シナリオ3:登録に失敗し、エラーコードが返される。
シナリオ4:しばらく正常に動作した後、電話機が突然登録を失い、ネットワーク接続が切断される。電話機を再起動すると、ネットワーク接続が復旧する。
シナリオ5:電話機は登録済みと表示されるが、PBXは内線がオフラインまたは未登録と報告する。
アカウント設定の送信後、すぐに登録がタイムアウトする
1. 症状:
SIPアカウントパラメータを入力して送信すると、電話機に登録中...と表示され、しばらくするとステータスが登録タイムアウトに変わります。
2. 考えられる原因:
電話機はSIP登録リクエストを送信するが、サーバーから応答を受信しないため、タイムアウトが発生します。
① 電話機とサーバー間にネットワーク接続の問題がある可能性があります。または、SIP設定が誤っている可能性があります(サーバーアドレスやポートが間違っているなど)。
② アカウントがシステムによって一時的にブラックリストに登録されている可能性があります。一部のIMS環境では、同じアカウントが頻繁に登録されると、システムがそれを疑わしい動作と見なし、一定期間(例:10分間)登録をブロックする場合があります。
③ 電話機がプライベートLANにあり、パブリックSIPサーバーに登録する場合、サーバーの応答が電話機に正しく到達しない可能性があります。
3. 解決策:
① 電話機とサーバーが適切に通信できることを確認し(例:Ping)、すべてのSIPパラメータ(特にサーバーアドレスとポート)が正しいことを確認します。
② 登録を再送信する前にしばらく待つか、サーバー上に新しいアカウントを作成します。異なる電話機で同じアカウントを繰り返し登録しないでください。
③ 内部電話機がパブリックSIPサーバーに登録する場合は、rportと特殊サーバー互換性を有効にしてから、再度登録を試みます。
電話機がしばらく正常に動作した後、登録がタイムアウトする
1. 症状:
電話機は正常に登録され正常に動作しますが、しばらくすると(通常約1日後)、登録ステータスが登録タイムアウトに変わります。電話機は発着信できなくなります。電話機を再起動するか、ローカルSIPポートを変更すると、再び登録に成功します。
2. 考えられる原因:
この問題は、特定のルーターを使用する環境でよく発生します。ルーターが再起動されるか、新しいパブリックIPアドレスを受け取ると、電話機から送信されたパケットがルーターの以前のパブリックIPを使用して変換される可能性があります。その結果、サーバーの応答が電話機に戻らず、登録タイムアウトが発生します。
電話機を再起動するか、ローカル登録ポートを変更すると、ルーターは送信元アドレスを正しく書き換え、登録は再び機能します。
3. 解決策:
新しいファームウェアバージョンは、動的なローカルSIPポートメカニズムをサポートしています。登録に失敗またはタイムアウトした場合、電話機は新しいローカルポートを使用して次の登録を試みます。公式ウェブサイトから最新のファームウェアをダウンロードするか、テクニカルサポートに連絡してバージョンのサポートを確認してください。
登録に失敗し、エラーコードが返される
1. 症状:
SIPアカウント情報を設定して送信した後、電話機に登録失敗メッセージが表示されます。
① エラーコード403
② エラーコード404
③ エラーコード423
④ エラーコード5xx
2. 考えられる原因:
① 通常、ユーザー名またはパスワードが間違っているか、アカウントがサーバーで無効になっていることを示します。
② アカウントが存在しないことを示します。
③ 登録間隔が短すぎることを示します。
④ サーバー側の障害を示します。
3. 解決策:
① ユーザー名とパスワードを再確認し、管理者と一緒にアカウントの状態を確認します。
② 管理者にアカウントが存在するかどうかを確認してもらいます。
③ 電話機の登録有効期限間隔を長くします。
④ 管理者に連絡してSIPサーバーの状態を確認します。
しばらく正常に動作した後、電話機が突然登録を失い、ネットワーク接続が切断される
1. 症状:
電話機がしばらく正常に動作した後、突然登録を失い、ネットワーク接続が切断されます。電話機を再起動すると、ネットワーク接続が復元されます。
2. 考えられる原因:
一部のCiscoスイッチおよび特定のレイヤー2スイッチは、電話機で使用されるARPエージングロジックとは異なるARPエージングタイマーを使用します。スイッチ側のARPエントリが予想より早く期限切れになると、電話機のネットワーク接続が中断される可能性があります。
3. 解決策:
電話機を最新のファームウェアバージョンにアップグレードします。新しいファームウェアは、ARPエージングタイマーの手動設定をサポートしています。電話機のWebインターフェースで、ネットワーク - 詳細設定 - ARPエージング時間に移動し、必要に応じて値を1からN分に設定します。
電話機は登録済みと表示されるが、PBXは内線がオフラインまたは未登録と報告する
1. 症状:
電話機のディスプレイはアカウントが登録済みであることを示していますが、PBXは内線をオフラインまたは未登録として表示します。
2. 考えられる原因:
一部のネットワークでは、IPルーティングまたはNATはアクティブなままですが、PBXまたは電話機でNATキープアライブが有効になっていません。SIP登録応答が完了した後、継続的なUDPキープアライブトラフィックがないため、NATデバイスはデフォルトのUDPタイムアウト(多くの場合60秒)後にマッピングを削除します。
3. 解決策:
電話機のWEBインターフェース --- 回線 --- 詳細設定にログインし、SIPサーバーの要件に従ってキープアライブタイプとキープアライブ間隔を調整します。SIP OPTIONまたはUDPを試すこともできます。キープアライブ間隔は60秒未満に設定する必要があります。
以下の例では、X4U電話機を設定の参照モデルとして使用しています。
rportと特殊サーバー互換性を有効にする方法
電話機のWeb管理ページに移動し、回線 - 詳細設定をクリックし、Rportを有効にすると特殊サーバー互換性を設定するをチェックし、ページ下部の送信をクリックします。以下に示します。

ローカルポート更新を有効にする方法
電話機のWeb管理ページに移動し、回線 - 詳細設定をクリックし、ポート更新を有効にするをチェックし、ページ下部の送信をクリックします。以下に示します。

登録有効期限設定を変更する方法
電話機のWeb管理ページに移動し、回線 - 詳細設定 - 登録有効期限をクリックし、登録間隔を変更し、ページ下部の送信をクリックします。以下に示します。

ARPエージング時間を変更する方法
電話機のWeb管理ページに移動し、ネットワーク - 詳細設定 - ARPエージング時間をクリックし、必要に応じて値を1からNに設定し(できればスイッチのエージングタイマーに合わせる)、ページ下部の送信をクリックします。以下に示します。

キープアライブタイプを変更する方法
電話機のWeb管理ページに移動し、回線 - 詳細設定 - キープアライブタイプをクリックします。SIPサーバーがサポートするモードを選択するか、SIP OPTIONまたはUDPを試し、ページ下部の送信をクリックします。以下に示します。
